picprojects.net Forum

picprojects.net Forum
It is currently Fri Sep 21, 2018 8:10 pm

All times are UTC




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: PIC Pprogrammer
PostPosted: Mon May 26, 2014 9:47 pm 
Offline

Joined: Mon May 26, 2014 8:18 pm
Posts: 1
Hi
i constructed a PIC programmer and i've attached a schematic. PGMpic recognize it as jdm programmer and with the test function i've checked that the correct voltage is applied to each pin.
Anyway when i try to program F16873 i got the following error message:
Code:
Checking connection of JDM Programmer ...
JDM Programmer connected and initialized!
Autodetecting PIC ...
Calibrating delay: 50us delay took 588us (loop counter=1362)
PIC unknown! Programming may fail!!
Warning: Configuration bits not found in HEX file!
JDM Programmer connected and initialized!
Autodetecting PIC ...
Calibrating delay: 50us delay took 0us (loop counter=1)
PIC unknown! Programming may fail!!
Configuration bits found in HEX file (config memory length = 16 bytes)!
Erasing Device ...
Erasing finished!
Programming started ...
Verify Error: Code Mem 0x000000: PIC=0x3666 Buf=0x1993
Verify Error: Code Mem 0x000002: PIC=0x3333 Buf=0x19B3
Verify Error: Code Mem 0x000004: PIC=0x19B3 Buf=0x3666
Verify Error: Code Mem 0x000006: PIC=0x3333 Buf=0x1333
Verify Error: Code Mem 0x000008: PIC=0x3332 Buf=0x1999
Verify Error: Code Mem 0x00000A: PIC=0x3333 Buf=0x3366
Verify Error: Code Mem 0x00000C: PIC=0x3332 Buf=0x3336
Verify Error: Code Mem 0x00000E: PIC=0x3333 Buf=0x1326
Verify Error: Code Mem 0x000010: PIC=0x2666 Buf=0x1933
Verify Error: Code Mem 0x000012: PIC=0x3333 Buf=0x3666
Verify Error: Too much errors in Code Mem, giving up!
Verify Error: Cfg Mem 0x00000E: PIC=0x3333 Buf=0x1333
Programming finished with verify errors!
Operation took  35.0 seconds!


Any idea? Some suggestion?


Attachments:
PICProg.jpg
PICProg.jpg [ 55.16 KiB | Viewed 8233 times ]
Top
 Profile  
 
 
 Post subject: Re: PIC Pprogrammer
PostPosted: Fri Jul 04, 2014 6:34 pm 
Offline

Joined: Fri Oct 28, 2011 5:18 pm
Posts: 225
Hi,
sorry for the late reply - I was very busy during the last month ...

Regarding your problem:
Have you selected "autodetect" for the PIC or have you manually selected the PIC which is connected?
PICPgm was unable to detect the device at all as we see in the log:
Quote:
PIC unknown! Programming may fail!


That means there is a general communication problem.
You can try the following:
- Even though you do high voltage programmen, pull the PGM pin to GND. PICs have the LVP (low voltage programming) bit set as factory default. This could lead to problems - I have also had such problems which where fixed after connecting the PGM pin to GND - at least as long as the LVP bit is not changed to HVP.
- You can also add some very small capacitors as filters to from PGD to GND and PGC to GND ("PGD and PGC filtering").
- If this doesn't helb, check the further things mentioned in the troubleshooting guide (http://picpgm.picprojects.net/troubleshooting.html).

Hope this helps you!

Regards,
Christian


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group