picprojects.net Forum

picprojects.net Forum
It is currently Sat Jun 24, 2017 5:13 pm

All times are UTC




Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: Verify errors with K8048 on Win7 and Linux
PostPosted: Sun Apr 30, 2017 5:32 pm 
Offline

Joined: Sun Apr 30, 2017 5:22 pm
Posts: 1
I'm struggling to get my K8048 working with PICPgm -- I've tried both Win7 and Linux and I'm getting the same errors on both platforms.

I've been able program a PIC and run a program on it with the Velleman supplied software (PicProg2009) on Win7 so I'm confident that my serial card and programmer are good.

Here's a log of a session that fails:

Checking connection of Velleman-Kit K8048 ...
Velleman-Kit K8048 connected and initialized!
Autodetecting PIC ...
Using QueryPerformanceCounter function for microseconds delay.
Testing delay: 100us delay took 599us (loop counter = 100)
Detected PIC16F627, device ID 0x07A0!
Configuration bits found in HEX file (config memory length = 16 bytes)!
Velleman-Kit K8048 connected and initialized!
Detected PIC16F627, device ID 0x07A0!
Erasing Device ...
Erasing finished!
Programming started ...
Verify Error: Code Mem 0x000000: PIC=0x0000 Buf=0x2812
Verify Error: Code Mem 0x000002: PIC=0x0000 Buf=0x3064
Verify Error: Code Mem 0x000004: PIC=0x0000 Buf=0x00A1
Verify Error: Code Mem 0x000006: PIC=0x0000 Buf=0x3064
Verify Error: Code Mem 0x000008: PIC=0x0000 Buf=0x00A0
Verify Error: Code Mem 0x00000A: PIC=0x0000 Buf=0x1805
Verify Error: Code Mem 0x00000C: PIC=0x0000 Buf=0x281F
Verify Error: Code Mem 0x00000E: PIC=0x0000 Buf=0x1885
Verify Error: Code Mem 0x000010: PIC=0x0000 Buf=0x281F
Verify Error: Code Mem 0x000012: PIC=0x0000 Buf=0x1905
Verify Error: Too much errors in Code Mem, giving up!
Verify Error: Cfg Mem 0x00000E: PIC=0x0261 Buf=0x3F61
Programming finished with verify errors!
Finished in 14.0 seconds!

I've got the delay set at midway (where it was for the Velleman software).

If it matters, I've got the jumpers installed that enable the oscillator for the PIC16F727. The toggle switch is in the PROG position.

Can anyone offer some insight on these errors?

Thanks,
T.


Top
 Profile  
 
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group